dcsimg

Installation Page 2

By M.A. Dockter (Send Email)
Posted Mar 8, 2001


The ISC Web site states that in order to run BIND, you must be running a Unix-based system with an ANSI C compiler, basic POSIX support, and a good pthreads implementation. The following operating systems have been successfully configured in the past by ICS to run BIND:

  • AIX 4.3
  • COMPAQ Tru64 UNIX 4.0D
  • COMPAQ Tru64 UNIX 5 (with IPv6 EAK)
  • FreeBSD 3.4-STABLE, 3.5, 4.0, 4.1
  • HP-UX 11
  • IRIX64 6.5
  • NetBSD current (with unproven-pthreads-0.17)
  • Red Hat Linux 6.0, 6.1, 6.2, 7.0
  • Solaris 2.6, 7, 8

Because BIND is Unix-based, installation can be a nightmare. Downloading BIND, however, is easy. Visiting www.ics.org and going through the process of downloading the latest version of BIND is the best (and usually only) way to get the program. All you have to do is download the install file to an empty directory; then enter the following command into the prompt:

gunzip < bind-src.tar.gz | tar xf - 

This will extract the BIND source code into the current directory. After extraction is complete, you will need to compile the source code. It would be nearly impossible to explain how to install it on every given machine that it can be installed on, so your best bet is to check out the src/INSTALL file for instructions straight from ICS.

Believe it or not, BIND is also available for Windows NT. It comes uncompiled though, so you'll need a C++ compiler such as Visual C++ 6.0 to compile it into a functional binary. The NT version can be downloaded from ftp://ftp.isc.org/isc/bind/src/8.2.2-P5/bind-src.tar.gz. The source that needs to be compiled should be in src/port/winnt.



Comment and Contribute

Your name/nickname

Your email

(Maximum characters: 1200). You have characters left.